Installation error "file missing"

Matlab version: (R2018a)
Architecture : PCWIN64
Warning: The mosek optimizer could not be invoked from the command line. Most likely the path has
not been configured correctly. The mosek optimizer can still be invoked from the MATLAB
In mosekdiag (line 23)
mosekopt: C:\Users\Summy\Mosek\8\toolbox\r2014aom\mosekopt.mexw64
Invalid MEX-file ‘C:\Users\Summy\Mosek\8\toolbox\r2014aom\mosekopt.mexw64’: Missing dependent
shared libraries:
‘mosek64_8_1.dll’ required by ‘C:\Users\Summy\Mosek\8\toolbox\r2014aom\mosekopt.mexw64’.

Error in mosekdiag (line 44)
[r, res] = mosekopt(‘version echo(0)’);

how to tackle with this? I have read the guides but coudnt find the solution

If you installed Mosek manually i.e. without using the MSI installer then you must also manually add the folder with Mosek binaries to the environment variable PATH. This is mentioned in the Mosek install manual.

I tried this
addpath C:\Users\Summy\Mosek\8\tools\platform\win64x86\bin

I mean the global environment variable PATH of the operating system.

If you really must do it inside Matlab then try

setenv(‘PATH’, [getenv(‘PATH’) ‘;C:\Users\Summy\Mosek\8\tools\platform\win64x86\bin’]);

when you start yout matlab session.

Sorry I dont have much knowledge… thankyou for guidance… I did this… what is the next step to follow?

See if it helped and if not then I suggest to continue on the Mosek google group.

I did this

addpath C:\Users\Summy/mosek/8/toolbox/r2014aom

Matlab version: (R2018a)
Architecture : PCWIN64
The mosek optimizer executed successfully from the command line:
MOSEK Version (Build date: 2018-9-5 20:39:09)
Copyright © MOSEK ApS, Denmark. WWW:
Platform: Windows/64-X86
Version : 11.14
Host ID : “ce79cf0f1a22 cc79cf0f1a22”
License path : C:\Users\Summy\mosek\mosek.lic
Operating system variables
*** No input file specfied. No optimization is performed.
Return code - 0 [MSK_RES_OK]
mosekopt: C:\Users\Summy\Mosek\8\toolbox\r2014aom\mosekopt.mexw64
Found MOSEK version : major(8), minor(1), revision(63)
mosekopt is working correctly.
Warning: MOSEK Fusion is not configured correctly; check that mosek.jar is added to the
In mosekdiag (line 85)

Is this now installed correctly?

I tried cvx_setup

Mosek unknown C:\Users\Summy\Mosek\8\toolbox\r2014aom
A CVX Professional license is required.

Does the trial license doesnt work with this?

As far as Mosek is concerned the message “mosekopt is working correctly” means you’re good.

CVX Professional (Academic) is needed to use Mosek under CVX. The free version of CVX does not allow use of Mosek.

I am facing the same problem as u mentioned above, have you got some result. If you have installed it successfully please tell me how to fix the problem.

No I separately installed Mosek

Is it work if we call in CVX?

NO in CVX it was asking for the professional license. I tried other solvers then… I was using it for Mixed Integer non linear problem