Disabled Solver

Why is this error comes up to me, although I am using MOSEK solver for about 10 days with no Problems?
Error using cvx_solver (line 49)
Solver unusable due to prior errors: Mosek

Error in optimIndic1 (line 47)
cvx_solver Mosek

When I typed “cvx_solver” to see if cvx can detect MOSEK, I found that it’s unfortunately disabled … Why is it disabled? How can I Enable it again?

Name Status Version Location

Gurobi 9.00 {cvx}\gurobi\w64
Mosek disabled 9.1.9 {cvx}\mosek\w64
SDPT3 selected,default 4.0 {cvx}\sdpt3
SeDuMi 1.3.4 {cvx}\sedumi

Does this apply? CVX installation disabled after I restart my computer

Is Mosek still in the MATLAB path? What does mosekdiag show?

Things you can try:
Starting new session of MATLAB
Reinstalling CVX
Rebooting computer

1 Like

Thank you for your reply,

No, I have not restarted my computer. You can say that it was working well a minute ago, and suddenly when I tried to run the optimization code again, it gave me such annoying message that it is disabled.

Now I tried to type “mosekdiag” in the command window and I am seeing this message:

Unrecognized function or variable ‘mosekdiag’.

I tried to start a new matlab session, and the problem is solved. Thank you very much.

Perhaps Mosek somehow got deleted from the MATLAB path (running or installing something which changed the path), but the changes to the MATLAB path weren’t saved. So when you started a new MATLAB session, the old version of the MATLAB path was restored.

1 Like