CVX setup failure on MacOS + MATLAB R2023b pre-release

I tried running cvx_setup and I get the following error:

ERROR: one or more MEX files for this platform are missing. These files end in the suffix “.mexmaca64”. CVX will not operate without these files

I tried solving this by several different approaches inspired by the following posts and replies, and none have worked:

I even tried lifting the gatekeeper (allowing apps installed from anywhere)

Specs: On a new MacBook Pro (Apple M2 pro, Apple Silicon), Ventura 13.5 running MATLAB R2023b pre-release

Full output:

CVX: Software for Disciplined Convex Programming (c)2014 CVX Research
Version 2.2, Build 1148 (62bfcca) Tue Jan 28 00:51:35 2020

Installation info:
Path: /Users/ethanburnett/MATLAB/cvx
MATLAB version: 23.2 (R2023b)
OS: Mac OS X aarch64 version 13.5
Java version: 1.8.0_382
Verfying CVX directory contents:
WARNING: The following files/directories are missing:
These omissions may prevent CVX from operating properly.
ERROR: one or more MEX files for this platform are missing.
These files end in the suffix “.mexmaca64”. CVX will not operate
without these files. Please visit

And download a distribution targeted for your platform.
Preferences: none found; defaults loaded.

ERROR: ----------------------
Error using cvx_setup
Error detected by cvx_version

The installation of CVX was not completed. Please correct the error
and re-run CVX_SETUP.

EDIT: Sorry, I’m not sure how I read that you have a problem with Mosek and not with CVX in general. It is probably the bias of me testing Mosek on M1 recently ;). Of course there isn’t any CVX natively for M1 (I wonder if there ever will be). You may have to live with Rosetta and the 64x86 toolchain until the author of CVX compiles a native M1 MeX file.

I will leave my misguided comment about Mosek below, just in case someone needs it:

I tested Mosek with Matlab R2023b M1-prerelease just a few days ago and everything was perfectly fine. Remember that you have to use Mosek at least version 10.1, before that there was no native M1 Mosek toolbox for Matlab, you had to do everything through the 64x86 Rosetta emulator to use Mosek in Matlab (or Matlab at all, for that matter).

Just follow 4 Installation — MOSEK Optimization Toolbox for MATLAB 10.1.11 to install and fully test Mosek before you proceed to try CVX. If there are still issues you can also contact Mosek support.

@ethanburnett , have you figured it out?

I have the very same problem, but with MATLAB 2023B release and not the pre-release. I have tried everything covered in this post, and the suggestions made in these posts:

Installing CVX on Mac new with M1 chip
Installing CVX on a new Mac

I’m also on a Apple M2 pro with venture 13.5.2.

If someone has any more suggestions, I’m happy to test them!

It doesn’t matter if it is release or prerelease. If you installed Matlab for Apple Sillicon (MACA architecture) then there simply is no CVX build for it. Maybe @mcg you want to make a native M1 release?

Your only choice is to install the release for Intel x86 processors (MACI) and it will be ran via Rosetta, like all previous Matlab releases for MAC were running on the M1 MACs.

I guess I will have to install another version of MATLAB then.

Thanks for the swift replay!

You can install R2023B, just choose the installer for OSX x86 and not OSX M1, or whatever the latter is called (ARM64?).

Ended up with 2023b for other MATLAB things and 2023a for MATLAB with cvx. Perhaps I could have gone with 2023b for both, but didn’t want to risk it :slight_smile:

I followed this post to get cvx up and running:
Installing CVX on a new Mac

For anyone finding this post later on, you have to do the “repeat” process for like 10-15 times, so hang in there. It’s worth it!