Installing CVX Version 2.2 Build 1148


I am trying to install CVX version 2.2 on R2019a MATLAB on windows machine. After the installation, I get this warning.

“Verfying CVX directory contents:
WARNING: The following files/directories are missing:
These omissions may prevent CVX from operating properly.”

The installed CVX seems to work though.

Please should this be a concern or maybe I didn’t install it correctly or CVX should still work fine?

Thank you.

My sedumi directory under the cvx 2.2 build 1148 directory has the file .travis.yml . Does your installation have such a file?

I presume if there would be any difficulties, it would only be when SeDuMi is invoked as the solver.

Thank you for your quick reply Mark. Mine does have “.travis.yml”. I am not sure if the dot before the t matters.

I suppose you can try re-unzipping and reinstalling CVX. Other than that, I don’t know, except hope for the best.

Actually, there is a dot before the t , as I have now corrected.

Oh ok.

I installed it a second time. I will try again then. Thank you.

I just re-ran cvx_setup and got the same warning message as you - I hadn’t paid attention to it on the first installation. Perhaps this is a new glitch associated with CVX 2.2, which is a new version. I don’t know whether this is substantive, or just an erroneous (i.e. non-justified) warning.

Oh ok. I now understand it. Please I will wait for any update or development then.

Thank you Mark.

I have to re-run cvx setup twice to avoid below message. It is coming after few runs and can you explain the way to avoid. I am using R2018b and also tried with 2014.
Also I am having the same warning mentioned above.

Error using cvx_license
Invalid option: -4

              ’ƒumº×ya·Íe²ˆ<9	|µÝ½T„Å—ªÉüeÀCغt†‡L¥=!Ó7aG¼—÷­ä¥ZO®|¯OR‡š„”Òç.ý6Õèé‚ÕdÖÜìI¼‡©]‘Jœ–Üîèo|”Ó3 /™â@³¶H ŽpÁýÄçô¢ñ‰Ê7HÆü½ÎÍ:]




              ¬5Šâ &ZcùU©Ãǧ‚ðkÑub«o*ñ—ÆumËÚþòÑ1ŽKv:Ô°,uFèïç­íŖGü›INª/MÒsüÝë{¿å=„æݛ#uýÞKç³&ß+]âÒ


              OœÇóR-sá㝎…¤Ùnû&—¬__?!t‘Ú¹å90›pŒŒíÈJÉ@¶öUÁUÓHX‰MëхIÉßú¤õ?Éa„¦NãC!r‹„"ªi#”g8é¤Õ5²œQµê¬ÆáKUöDD“.”ÍNŠ„)=¾Ïe´µåBPü'ö¡äz[\ö'þØaqð\·³Ìå0S’~à­Ð;gøwÚn€ØóE¤þÐÎg\:%o`SÍ82ï­È)J¼tò,Qœ2‘°æÌf»,€ø¥šAýV"ºÍ£*ˆN±hوG. œŽ,&¯G¦è®ùوǧÈe—£LÇrÞ\´:¢¾¢€AHª¢êªµ7ªäîrvà×ý˜Ã
              W@¿SçKÌÚ¶esŽA¦¸Í¸m"L䄯rÝX ?Û &‡¹+\ÄÏ`_Ž	˜<)ª;

ØW 2­Ô·0̶.•’»Ï9%åºOÄÀ؟äÇ»wö+’±’ŸX-~ÇzÁaÍe¤:O‡•YšŸÎMpž©šŸÐ 2}2óeu«Ã°+àIÉp±ÎS0_zÝËXäá’3 p¡<ځ46‹’ñžÑM!×~’ÕvXÇËàënMàbñ·¿x9“;
Saving updated preferences…done.
Testing with a simple model…done!

To change the default solver, type “cvx_solver <solver_name>”.
To save this change for future sessions, type “cvx_save_prefs”.
Please consult the users’ guide for more information.

Forgot to mentioned. I have academic licence and installed mosek. This is not happening everytime, but time toi time and I have to cvx to work with my code, after I got the above message.