Installation issues about mosek

Installation problems with mosek have plagued me for almost a long week.
I have installed a cvx ,and after enter “cvx_setup” in the matlab command window, there exist such that sever informations as follows:
(1) Installation info:
Path: D:\matpower7.1\matlab_trading\cvx
MATLAB version: 9.6 (R2019a)
(2)Installed license:
No license installed.
No valid licenses found.
(3)Setting CVX paths…already set!
Searching for solvers…5 shims found.
2 solvers initialized (* = default):

  • SDPT3 4.0 {cvx}\sdpt3
    SeDuMi 1.3.4 {cvx}\sedumi
    3 solvers skipped:
    Could not find a GLPK installation.
    Gurobi unknown {cvx}\gurobi\w64
    No valid Gurobi license was found.
    Mosek 9.1.9 {cvx}\mosek\w64
    Using MOSEK with CVX requires an academic MOSEK license
    or a MOSEK-enabled CVX Professional license.
    I am eager to learn the cvx ,so want to learn the mosek solver.
    I have downloaded a stand-alone mosek,which is" 64 bit x86,Windows 10, Server 2016 or newer" and is intalled located “e:\Program Files\Mosek”.
    I have applied a personal academic licence located in “e:\Users\Administrator\mosek\mosek.lic”.
    After start Matlab for locating files in the MOSEK Optimization Suite and settting up the paths, I enter a expression that is"addpath \mosek\10.0\toolbox\r2017aom" in the matlab command window. However when enter a command “mosekdiag”, a expressin “No funciotn or variable ‘mosekdiag’ is defined” is showed again!
    I have sended a email to for solveing the question, but it’s a pity, the question is still existing.
    Just now ,I have written a email for sovling it again. But it takes seveal more hours to get a reply, the problem may not ncecessarily be solved yet. So I would like to write these in the forum, hoping extensive and timely help. I really want to fix this problem quickly and use the mosek solver as soon as possible.
    Please help me !Thanks everyone who can help me!

Just FYI we live in Denmark and are just starting to wake up again.

I would think you have to do

addpath e:\Users\Administrator\mosek\10.0\toolbox\r2017aom

to get it working.

adddpath is a standard Matlab command to add paths to the files you want included. In your case most likely is

addpath "E:\Program Files\Mosek\10.0\toolbox\r2017aom"

and if not then find the full path to where mosekdiag actually is in your installation and use it here.

Thank you for your help!
The question has been solved!