Error message during installation on Mac

Hi all,

i’m trying to install cvx on my mac and i kept on getting this error message:
UNEXPECTED ERROR: -------------------------------------------------------------------------------------------
Invalid MEX-file
0x0006): tried:
(code signature in
not valid for use in process: library load disallowed by system
(no such file),
(code signature in
not valid for use in process: library load disallowed by system
Error in qops (line 25)
Fu = mexqops(pblk{2},w,f,options);
Error in blkcholfun (line 28)
gamx = qops(blk,X,X,2);
Error in blkcholfun (line 44)
[Xchol{p},indef(p)] = blkcholfun(blk(p,:),X{p}); %#ok
Error in sqlpmain (line 180)
[Xchol,indef(1)] = blkcholfun(blk,X);
Error in sqlp (line 242)
Error in cvx_run_solver (line 50)
[ varargout{1:nargout} ] = sfunc( inputs{:} );
Error in cvx_sdpt3>solve (line 362)
[ obj, xx, y, zz, info ] = cvx_run_solver( @sqlp, blk, Avec, Cvec,
b, OPTIONS, ‘obj’, ‘x’, ‘y’, ‘z’, ‘info’, settings, 5 ); %#ok
Error in cvxprob/solve (line 435)
[ x, status, tprec, iters ] = shim.solve( At, b, c,
cones, quiet, prec, solv.settings, eargs{:} );
Error in cvx_end (line 88)
solve( prob );
Error in cvx_setup (line 213)
Please report this error to support, and include entire output of
CVX_SETUP in your support request.

my guess would be it might’ve been the security settings on my mac are to vigorous…? but i chose the “allow anyways” option to override macos’s attempt to not open files downloaded from unrecognized websites :((

Has this error appeared for anyone else before? I tried google it but seems like im the only one that runs into it…and i’m using an older version of matlab (r2021b).

many thanks in advance!

Perhaps these posts will help: