Dot indexing is not supported for variables of this type

Hi! I am running some matlab script on HPC clusters (Stanford’s Sherlock). I get this error message

Dot indexing is not supported for variables of this type.

Error in cvx_global (line 76)
osolvers = cvx___.solvers.list;

Error in cvxprob (line 4)

Error in cvx_begin (line 41)
assignin( ‘caller’, ‘cvx_problem’, cvxprob( varargin{:} ) );

Error in MC (line 15)

My script runs perfectly on my own laptop (the script contains a line that runs cvxstartup.m at the top), and on login nodes on the HPC cluster. This problem only appears when I try to run it on compute nodes. Would really appreciate any help on how to troubleshoot this.



Hi, I have excatly the same issue. I couldn’t find a solution in any other forum either. Did you solve it?

Just ran into this problem and fixed it by re-installing cvx. My setup:

  • MATLAB R2019a
  • Was running CVX v2.1 Build 1123 when I encountered the error; updated to CVX v2.1 Build 1127 (most up-to-date download available as of this post date) and the error went away.

Hope this helps!

Hi, I also have the same problem. Have you solved this problem and how did you solve it? Thanks!

Has anyone found the solution to the above problem? My MATLAB scripts runs perfectly on my laptop which has the MATALB 2017 version. But when I run it on the host server which has MATLAB 2019 version, I get this error that dot indexing is not supported for variables of this type for the variable cvx___.solvers.list, cvx___.solver.selected.

Kindly help if anyone has solution.


I had the same problem with Matlab 2018b and CVX 2.1. It is solved after running ‘cvx_setup’.

1 Like

I am using CVX on MATLAB Online, which runs under Linux system. I had the same problem, and thank you for the tips about running cvx_setup, it solved the problem!!!