Error: Function 'subsindex' is not defined for values of class 'struct'

(os12) #1

when ever i run CVX (even with the “quickstart” example ) i get this error:

Function ‘subsindex’ is not defined for values of class ‘struct’.

Error in cvxprob/solve (line 423)
[ x, status, tprec, iters, y ] = shim.solve( At, b, c,
cones, quiet, prec, solv.settings, eargs{:} );

Error in cvx_end (line 88)
solve( prob );

Error in quickstart (line 28)

i am using: mac os, matlab R2016b.
maybe because both CVX and matlab have a function called “solve”!!

UPDATE: when i tried the same code/codes on windows 10, matlab R2012a it worked normally without error !!


I met the same problem with matlab 2016b , win10

Installation info:
Path: C:\Users\DK\Documents\MATLAB\cvx
MATLAB version: 9.1 (R2016b)
OS: Windows 8 amd64 version 6.2
Java version: 1.7.0_60
Verfying CVX directory contents:
No missing files.

(Chappell Wu) #3

Do you solve the problem? I have met the same problem.

(os12) #5

No , i just used another computer (windows pc)


It is quite a curious error, and even I faced the same one (Win10, Matlab 2018a). At one point using a ‘clear all’ command and rerunning the code worked, so I am sticking with that.