Error of Index in CVX (LP programme)


This is my code:

A=[1 -1 1;3 2 4;3 2 0];
  variable x(n);
  minimize (f'*x);
  subject to
      A*x <= b;
      x >= lb;

However, after running I got this error:

Calling SDPT3 4.0: 6 variables, 3 equality constraints

Status: Error
Optimal value (cvx_optval): NaN

Unable to use a value of type struct as an index.
Error in cvxprob/solve (line 435)
[ x, status, tprec, iters ] = shim.solve( At, b, c, cones, quiet, prec, solv.settings, eargs{:} );
Error in cvx_end (line 88)
solve( prob );
Error in cvx_test (line 12)

Iam thankful if you help me

There must be something wrong in your installation, or your MATLAB session got corrupted.

Try it in a new MATLAB session. if that doesn’t resolve the problem, reinstall CVX, and make sure you use CVX 2.2

Today I tested my code on another computer but with the same CVX version and MATLAB, and it is worked. I don’t what exactly I did wrong with my CVX installestion.

Best regards

I restarted My MATLAB and my problem is solved.
Now, I have another problem.
I requested a license to use MOSEK solver. I put my academic email address and I received the mat file. I typed the CVX_setup license directory and finally, everything has done correctly.
However, I decided to use the license on another computer. I requested a license by adding HOST and I used the same email address but a different username and host. I received another mat file But it doesn’t work. I restart the MATLAB. But, it still has the problem. Should I order a new license?

Best regards

Perhaps you should start a new thread at , since this is a Mosek licensing issue.