How to use MOSEK in CVX?

(Kushagra Singhal) #21

But i got an academic license… is there a way to solve the problem?

(Kushagra Singhal) #22

It worked after adding the host name to my license. :smile:

(Michael C. Grant) #23

Yes, entering the correct information into the license is essential.

(Kushagra Singhal) #24

Is there a way to make mosek run faster and on big problems. Is there a limit on how big a problem can it solve? it is taking a lot of time solving for 300 X 300 SDP problem. I want to scale it to around 1000 X 1000

(Michael C. Grant) #25

Sorry, it looks like your problem is just too big to get good results with CVX and/or MOSEK. You’ll have to invent your own approach! Time for a journal article! :slight_smile:

(Erling D.Andersen) #26

300x300 SDP does not sound large for MOSEK. It solve quite quickly unless you have a lot of constraints.

(Kushagra Singhal) #27

I have equality constraints on the diagonal elements of the variable X…so 300 equality constraints and the regular PSD constraint on X. BTW what do you mean by quick…i am working on an i7-4770 machine with 16 gb RAM and 3.4 GHz clock speed.

(Erling D.Andersen) #28

Well, what do you mean by slow? Could you include the log output. That would qualify the discussions quite a bit.

A problem with say a 5000 x 5000 SDP variable is starting to get large. 300 x 300 is small.

(Kushagra Singhal) #29

I realize the problem in scaling is due to the RAM. I will try on other servers with more RAM to see how it scales.

(Edgar Arribas) #30

Hi, I got a very similar error when trying to use mosek solver with the CVX toolbox.

I have a CVX Professional license as an academic, I have successfully installed Mosek 7 with an academic license, and I have added the path to Mosek in the Matlab command prompt. Still, when I run cvx_set /path/to/my/license/license.dat it skips the mosek solver and the line of the Status it says “Status: invalid:user”.

How can I use Mosek with CVX? Can anybody help me?

Thanks in advance.

(Michael C. Grant) #31

“invalid:user” means the username you added to the license does not match your actual username. If you type cvx_version or cvx_setup, the output gives you exactly the host ID and username you should be using.

(Edgar Arribas) #32

Oh! I thought I was using the correct user but in fact… I wasn’t. Thanks for the reply!


hello, I face the same problem with you, but the problem still exist after I installed the academic license. Can you help me?
With the command: mosekopt, the output showed

MOSEK Version (Build date: 2016-12-2 15:01:24)
Copyright (c) 1998-2016 MOSEK ApS, Denmark. WWW:
Platform: Windows/64-X86

Then i entered the command: cvx_setup d:\cvx_license.dat. The ourputs are
CVX: Software for Disciplined Convex Programming ©2014 CVX Research
Version 2.1, Build 1127 (95903bf) Sat Dec 15 18:52:07 2018
Installation info:
Path: D:\cvx-w64\cvx
MATLAB version: 8.1 (R2013a)
OS: Windows 7 amd64 version 6.1
Java version: 1.6.0_17
Verfying CVX directory contents:
No missing files.
Path: C:\Users\lenovo\AppData\Roaming\MathWorks\MATLAB\cvx_prefs.mat
License host:
Username: lenovo
Host ID: dc53603119ba (net5,
Installed license:
Also in file: d:\cvx_license.dat
Organization: beijing university of technology
Contact: Li xiaowei (
License type: academic
Named user: lxw_fc, lenovo
Host ID: 7085c24dbb1f, dc53603119ba
Expiration: 2019-12-18 (318 days remaining)
Status: verified
Setting CVX paths…already set!
Searching for solvers…5 shims found.
2 solvers initialized (* = default):
* SDPT3 4.0 {cvx}\sdpt3
SeDuMi 1.34 {cvx}\sedumi
3 solvers skipped:
Could not find a GLPK installation.
unexpected error:
Reference to non-existent field ‘folder’.
Error in D:\cvx-w64\cvx\shims\cvx_gurobi.p>cvx_gurobi (line
Error in cvx_setup (line 83)
tsolv = feval( tsolv.sname, tsolv );
unexpected error:
Reference to non-existent field ‘folder’.
Error in D:\cvx-w64\cvx\shims\cvx_mosek.p>cvx_mosek (line 46)
Error in cvx_setup (line 83)
tsolv = feval( tsolv.sname, tsolv );
Saving updated preferences…done.
Testing with a simple model…done!
To change the default solver, type “cvx_solver <solver_name>”.
To save this change for future sessions, type “cvx_save_prefs”.
Please consult the users’ guide for more information.

However the problem still exist.
svx_solver mosek
Undefined function ‘svx_solver’ for input arguments of type ‘char’.

What 's the problem?
Thanks in advance.