Error in cvx_mosek


(Atefe) #1

I installed mosek and when I use ‘mosekdiag’ I get
Operating system variables
PATH :

*** No input file specified. No optimization is performed.

Return code - 0 [MSK_RES_OK]

mosekopt: C:\Program Files\Mosek\8\toolbox\r2014a\mosekopt.mexw64
Found MOSEK version : major(8), minor(1), revision(72)
mosekopt is working correctly.
MOSEK Fusion is working correctly.

I have an academic license for CVX when I use
cvx_setup /path/to/your/cvx_license.dat
I get
Setting CVX paths…already set!
Searching for solvers…5 shims found.
2 solvers initialized (* = default):

  • SDPT3 4.0 {cvx}\sdpt3
    SeDuMi 1.34 {cvx}\sedumi
    3 solvers skipped:
    GLPK
    Could not find a GLPK installation.
    C:\Users\Atefe\Desktop\cvx\shims\cvx_gurobi
    unexpected error:
    Reference to non-existent field ‘folder’.
    Error in cvx_gurobi
    Error in cvx_setup (line 83)
    tsolv = feval( tsolv.sname, tsolv );
    C:\Users\Atefe\Desktop\cvx\shims\cvx_mosek
    unexpected error:
    Reference to non-existent field ‘folder’.
    Error in cvx_mosek
    Error in cvx_setup (line 83)
    tsolv = feval( tsolv.sname, tsolv );
    Saving updated preferences…done.
    Testing with a simple model…done!

To change the default solver, type “cvx_solver <solver_name>”.
To save this change for future sessions, type “cvx_save_prefs”.
Please consult the users’ guide for more information.

Please help me.


(Mark L. Stone) #2

Please show the results of cvx_version. Which version of mosek are you using?

If you are using CVX 3.0beta, please install CVX 2,.1 and try that.


(Atefe) #3

cvx version
CVX: Software for Disciplined Convex Programming ©2014 CVX Research
Version 2.1, Build 1127 (95903bf) Sat Dec 15 18:52:07 2018

mosek version
MOSEK Version 8.1.0.72 (Build date: 2018-12-18 11:03:49)
Copyright © MOSEK ApS, Denmark. WWW: mosek.com
Platform: Windows/64-X86


(Mark L. Stone) #4

I think you will have to wait for @mcg to provide assistance on this.

However, in the meantime, I suggest reinstalling CVX 2.1 and see whether that works. Given that you receive a similar error message with gurobi, I suspect the problem is with the CVX installation, not with mosek. Also, it may help him to diagnose if you provide the full output of cvx_version, not just the cvx version.


(Atefe) #5

full cvx version


CVX: Software for Disciplined Convex Programming ©2014 CVX Research
Version 2.1, Build 1127 (95903bf) Sat Dec 15 18:52:07 2018

Installation info:
Path: C:\Users\Atefe\Desktop\cvx
MATLAB version: 8.6 (R2015b)
OS: Windows 8 amd64 version 6.2
Java version: 1.7.0_60
Verfying CVX directory contents:
No missing files.
Preferences:
Path: C:\Users\Atefe\AppData\Roaming\MathWorks\MATLAB\cvx_prefs.mat
License host:
Username: Atefe
Host ID: fa163e8480e3 (eth0,172.17.3.68)
Installed license:
Organization: Iran University of Science and Technology
Contact: Atefe (a_pakzad@comp.iust.ac.ir)
License type: academic
Named user: Atefe
Host ID: fa163e8480e3
Expiration: 2020-01-15 (353 days remaining)
Status: verified


(Atefe) #6

@mcg please help me.


(Michael C. Grant) #7

Your version of CVX is way too old. You’ll have to update at least to R2016b I think.


(Atefe) #8

Dear @mcg
I downloaded cvx from
http://cvxr.com/cvx/download/
where can I download cvx 2016?


(Michael C. Grant) #9

Sorry I meant your Matlab version is too old.


(Atefe) #10

Dear @mcg
I tried with matlab R2016a and I got error.

  1. I installed mosek 8 and I copied mosek.lic in C:\Users\Atefe\mosek
    I used below codes in matlab:
  2. addpath ‘C:\Program Files\Mosek\8\toolbox\r2014a’
    3)cvx_setup C:\Users\Atefe\Desktop\cvx_license.dat

please help me to solve this problem.
matlab R2016a is too old?


(Atefe) #11

@Mark_L_Stone
do you know what is wrong?


(Erling D.Andersen) #12

You wrote

I tried with matlab R2016a and I got error.

So are we supposed to guess what error you got?
What about showing us the error you got.


(Atefe) #13

I wrote the errors above at the first of topic.


(Atefe) #14

Dear @mcg
I use windows. Is there something different for windows to set up?